I suggest you ...

allow users to filter apps not compatible with Android 1.5

Many phones are still stuck on Android 1.5 like those running MotoBlur or HTC Sense and many apps shown in the recomendations aren't compatible...

It would be nice to be able to filter those out like we can already do with 1.6, 2.0 and 2.1.

42 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Ankush GAnkush G shared this idea  ·   ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Martin KrischikMartin Krischik commented  · 

        Is it really worth it for spending precious developer time for the remaining 6.3% of Android Users still visiting the Marker with 1.5?

        I would say: NO.

      • Justin GibsonJustin Gibson commented  · 

        I agree. Why offer filters for pretty much every version of Android except for 1.5.

      • anthonianthoni commented  · 

        I also agree with this. I am one of those that is stuck on 1.5 through the incompetence of HTC and not upgrading.

        So this means I can not use your site at all. It also means that people like me can not use your site and thus you are losing out on a large market share.

      • jdsatyrjdsatyr commented  · 

        wholeheartedly agree is frustrating to try to install an app when stuck on 1.5 with a backflip and being told not available

      Feedback and Knowledge Base